Subject: Re: make: making .WAIT recursive
To: Alan Barrett <>
From: Martin Husemann <>
List: tech-toolchain
Date: 02/12/2006 11:58:00
On Sun, Feb 12, 2006 at 09:08:19AM +0200, Alan Barrett wrote:
>  Or would it be better to retain the
> existing behaviour of both .WAIT and .ORDER, but add new recursive
> variants of both (say ".WAITRECURSIVE" and ".ORDERRECURSIVE", or better
> names if anybody can suggest them)?

IMHO .WAIT is similar to an instruction reorder barrier in code - nothing
caused by the right hand side should be moved across to the left. Anything
else will only cause confusion.

So I'd say: yes, make it recursive, and no, don't bother to provide 
non-recursive variants.

Hmm, .ORDER sounds like a different notation for the same semantics, which
would imply to treat it just the same. (Though the different notation does
not associate the "barrier" idea.)