Subject: NetBSD Sparc64/gcc 2.95.3 compiler error
To: None <>
From: Ethan Blanton <>
List: tech-toolchain
Date: 05/30/2002 10:49:07
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I'm not sure if this is the right place for this message or not, but I
figured this was a good first forum.  This may need to go to the gcc
team.  I did a brief search for reports of this problem and found an
explanation of what might be happening in the GCC FAQ, but I am not
confident that what I found is applicable in this instance.

When building TightVNC from pkgsrc, I get the following error from

type1.c: In function CallOtherSubr':
type1.c:1698: fixed or forbidden register 32 (%f0) was spilled for class FP=
type1.c:1698: This may be due to a compiler bug or to impossible asm
type1.c:1698: statements or clauses.
type1.c:1698: This is the instruction:
(insn 190 223 229 (set (reg:SI 2 %g2)
        (fix:SI (fix:DF (reg:DF 64 %f32)))) 257 {fix_truncdfsi2} (insn_list=
:REG_DEP_AN_TI 40 (insn_list 189 (nil)))
    (expr_list:REG_DEAD (reg:DF 64 %f32)
The GCC FAQ seems to indicate that this error can be intentionally
generated by code (and gives a way to shut the assembler up), but I
get the impression that you have to muck with asm directives to
generate it yourself.  I see no asm in type1.c, so I'm assuming it is
a compiler bug instead...

This system is an Ultra 1/167MHz running the NetBSD-1.5ZC sparc64
snapshot from May 11, 2002.  I have also tried the latest (as of last
night, May 30) gcc from pkgsrc with the same result.

Someone please let me know if I'm barking up the wrong tree here.

If I've told you once, I've told you once
And once is all that you needed.
		-- The Refreshments, "Carefree"

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see