Subject: Re: Two problems on sparc64 (heh!)
To: Martin Husemann <>
From: Martin Husemann <>
List: tech-toolchain
Date: 01/19/2002 14:15:24
> I've seen this a few times before, then tried to debug it by building nbmake
> with "-g -pipe" options added manually to a copy of - but that version
> always worked and successfully build everything for me.
> Now this time it is not that easy, due to the autoconfig involved, but nbmake
> already is build with -g, so I just removed the "trap" statement to remove the
> temporary binary and ran gdb on the result:

Ok, since -g didn't make it (hmm), I modified to set
CFLAGS="-g -O2 -pipe" before configuring and building the bootstrap nbmake -
and besides this getting things much faster (hey, this is an U5 - so lousy 
disk performance, but 640 MB ram) it actually worked.

I have 

.if ${CFLAGS:N-pipe}
CFLAGS += -pipe

in my /etc/mk.conf, so I probably never compile anything without -pipe.

I suppose "-pipe" does not change any code generated - so this sounds more
like a pmap problem, doesn't it?