Subject: Re: "problem"
To: Todd Vierling <>
From: Andrew Brown <>
List: tech-toolchain
Date: 12/03/2001 17:10:21
>: i just tried to use for the first time and i ran into two
>: problems.  i'll start by saying this:
>: NetBSD tweedlebsd 1.5Y NetBSD 1.5Y (FROGS) #21: Sat Oct 6 19:06:01 EDT
>: 2001 andrew@tweedlebsd:/usr/src/sys/arch/alpha/compile/FROGS alpha
>                                                               ^^^^^
>Don't expect it to work.  The new toolchain will produce unusable alpha
>binaries at this time, and is thus *not* set as the default on alpha.  See
>the notes about platforms at the top of BUILDING.

i don't.  i've been convinced otherwise.  :)

>: which emits a rather ponderous error message "rm: /usr/dest: Device
>: busy".
>This should be a no-op error, only because /usr/dest is a mountpoint.  It
>isn't functionally relevant.  However, is careful to check return
>values much like make(1) does, and your build stopped after the "rm" for
>that reason.

hmm...i didn't see any evidence of this...and i did ultimately find
the nbmake that it maked.  of course, i was confused because
didn't emit any evidence of the build besides the message that it was
going to do such a thing.  i was expecting something more like the
standard make output when compiling something...

>I'll try to come up with a cleaner way to do the recursive rm (with some
>certainty) without tripping over the top-level directory.

it strikes me that

	rmrf () {(
		cd "$1"
		find .?* -name .. -o -print0 -prune | xargs -0 rm -r -f

	if $do_removedirs; then
		for f in $removedirs; do
			echo "===> Removing $f"
			$runcmd rmrf $f

might be just the ticket.  :)

|-----< "CODE WARRIOR" >-----|             * "ah!  i see you have the internet (Andrew Brown)                that goes *ping*!"       * "information is power -- share the wealth."