Subject: Re: "problem"
To: Andrew Brown <>
From: Todd Vierling <>
List: tech-toolchain
Date: 12/03/2001 16:57:50
On Mon, 3 Dec 2001, Andrew Brown wrote:

: i just tried to use for the first time and i ran into two
: problems.  i'll start by saying this:

: NetBSD tweedlebsd 1.5Y NetBSD 1.5Y (FROGS) #21: Sat Oct 6 19:06:01 EDT
: 2001 andrew@tweedlebsd:/usr/src/sys/arch/alpha/compile/FROGS alpha
Don't expect it to work.  The new toolchain will produce unusable alpha
binaries at this time, and is thus *not* set as the default on alpha.  See
the notes about platforms at the top of BUILDING.

: which emits a rather ponderous error message "rm: /usr/dest: Device
: busy".

This should be a no-op error, only because /usr/dest is a mountpoint.  It
isn't functionally relevant.  However, is careful to check return
values much like make(1) does, and your build stopped after the "rm" for
that reason.

I'll try to come up with a cleaner way to do the recursive rm (with some
certainty) without tripping over the top-level directory.

-- Todd Vierling <>  *  Wasabi & NetBSD:  Run with it.
-- CDs, Integration, Embedding, Support --