Subject: "problem"
To: None <>
From: Andrew Brown <>
List: tech-toolchain
Date: 12/03/2001 16:22:30
i just tried to use for the first time and i ran into two
problems.  i'll start by saying this:

# uname -a
NetBSD tweedlebsd 1.5Y NetBSD 1.5Y (FROGS) #21: Sat Oct  6 19:06:01 EDT 2001     andrew@tweedlebsd:/usr/src/sys/arch/alpha/compile/FROGS alpha
# ident
     $NetBSD:,v 1.27 2001/11/26 05:57:33 jmc Exp $
     $NetBSD:,v 1.27 2001/11/26 05:57:33 jmc Exp $
# TZ=UCT ls -lT .updated
-rw-rw-r--  1 root  wsrc  9 Nov 27 14:38:54 2001 .updated

the problems:

(1) there's a small chunk of code that reads

	# Remove the target directories.
	if $do_removedirs; then
		for f in $removedirs; do
			echo "===> Removing $f"
			$runcmd rm -r -f $f

which emits a rather ponderous error message "rm: /usr/dest: Device
busy".  i have /usr/dest mounted over nfs because i wasted all my
local disk space doing other silly things.  i don't know if anyone
really cares, but what i normally do in situations where i need to
remove stuff like this is

  mkdir .trash
  mv * .trash
  mv `find .?* -name .. -o -print -prune` .trash
  rm -rf .trash

since that's mount point agnostic.

(2) after i started like this:

	# RD=`echo /var/snap/snap-`uname -r`-`cat .updated`
	# ./ -b -d -r -D/usr/dest -R $RD proceeded to print out

	===> Bootstrapping nbmake
	/usr/src/tools/obj.alpha -> /usr/obj/alpha-on-alpha/tools.alpha
	===> DESTDIR path: /usr/dest
	===> TOOLDIR path: /usr/src/tools-alpha
	===> Removing /usr/src/tools-alpha
	===> Removing /usr/dest
	rm: /usr/dest: Device busy

and then it was done.  uh...there should be more than that, no?  the
only thing i could think of was that specifying -b might perhaps cause
it to do less work, but it didn't even come close to building nbmake
for me, much less a wrapper script or anything else.  huh?

|-----< "CODE WARRIOR" >-----|             * "ah!  i see you have the internet (Andrew Brown)                that goes *ping*!"       * "information is power -- share the wealth."