Subject: Re: Problem with make obj
To: Ian Fry <>
From: James Chacon <>
List: tech-toolchain
Date: 11/27/2001 12:34:51
Basically it'll only create dirs and not symlinks if it beleives it's not
inside of BSDSRCDIR. That's where symlinks, amd mounts, etc can confuse things.

I you actually wanna see what it's testing remove the leading @ from the
make obj rule near the bottom of


>On Tue, Nov 27, 2001 at 11:30:23AM -0500, James Chacon wrote:
>> Do this for me:
>> ls -ld /mnt/source/current
>I can't at the moment - I'm at work, and the machine this is affecting is at
>home. I'll do it when I get home.
>> Is that a symlink pointing to somewhere?
>No, not a symlink. /mnt/source is a seperate filesystem where I keep various
>source trees (both NetBSD and other projects). 'current' is a normal
>subdirectory, and the root of the -current source tree.
>> How did you run to generate nbmake?
>' -m arm26 -D /mnt/export/arm/root -t' usually. I looked at the
>generated wrapper, and the MKOBJDIRS line looked suspect, so I ran the nbmake
>in my TOOLDIR manually and produced the same result (directories created, not
>symlinks), so I don't think it's specific to the wrapper.