Subject: Re: two more bugs perry doesn't want to admit exists
To: Darren Reed <>
From: Jaromir Dolecek <>
List: tech-toolchain
Date: 11/23/2001 19:17:55
Darren Reed wrote:
> #1.
> using UNPRIVED=1 in /etc/mk.conf results in this with a r-o src, despite
> setting all the directory flags with
> nbinstall: open /data3/netbsd/src/METALOG: Read-only file system
> (perry doesn't think this is a problem...and insists that I'm not using
>  a "root objdir")

What OBJDIR do you use? I though METALOG would be created in root
of objdir, which must be writable of course.
> #2
> cd /data3/netbsd/src/sys/arch/sparc/conf && /www/obj/tool/bin/nbconfig  -b /data3/netbsd/src/sys/arch/sparc/compile/GENERIC -s /data3/netbsd/src/sys GENERIC
> config: cannot create /data3/netbsd/src/sys/arch/sparc/compile/GENERIC: Read-only file system
> *** Error code 2
> (perry doesn't think this never happened before, but prior to having to use
>  the new toolchain, it worked)

I don't see how this could ever have worked before, if 
/data3/netbsd/src/sys/arch/sparc/compile if RO. Did the pre-newtoolchain
tree passed objdir via -b to config too? This one definitely needs

Jaromir Dolecek <>
-=  Those who would give up liberty for a little temporary safety deserve  =-
-=  neither liberty nor safety, and will lose both.  -- Benjamin Franklin  =-