Subject: NetBSD-1.4 Objective C == borken?
To: None <>
From: Lou GLASSY <>
List: tech-toolchain
Date: 10/10/1999 23:09:19
(borken is an intentional misspelling of "broken" :-)

dear all,

Has anyone tried out the NetBSD 1.4 Objective-C part of gcc lately?

I tried it this evening, and lo, it barfeth mightily.

The source code for a simple program I used to test gnu objc 
is located at URL

A script session of "What Went Wrong" follows:

---cut here---

Script started on Sun Oct 10 22:28:35 1999
$ uname -a 
NetBSD caesar 1.4 NetBSD 1.4 (CARBON) #0: Mon Aug 16 12:28:57 PDT 1999     root@caesar:/usr/src/sys/arch/i386/compile/CARBON i386
$ gcc --version
$ make 
gcc -c main.m
gcc -c ColorType-implementation.m
gcc -o main ColorType-implementation.o main.o -lobjc
ld: ColorType-implementation.o: RRS text relocation at 0x180c for "___objc_class_name_Object"
$ ./main
objc runtime: cannot find class Object
Abort trap - core dumped
$ exit

Script done on Sun Oct 10 22:29:09 1999
---cut here---

I tried the same code under gcc-2.95.1 under both DUX 4.0e and Debian
Linux 2.1 (2.036 kernel), and it ran correctly, so I'm guessing the 
code itself is all right, and that my objc installation just needs
some extra tickling to get it to work too.  The program is little
more than a "hello world" kind of program, just enough to test out 
making objects and calling methods.

If this kind of objc bug has already been seen & fixed in 
1.4.1 or -current, tell me & I'll go upgrade... :-)

thanks in advance,


ps, a beginner-question:  what's the right way to report this kind
of thing?  submit a PR?  i looked in the old PR database, and saw
a PR from two years ago about objc, but it had been resolved
and closed, i thought -- ?

Monkey 347:      So what do you think of the ongoing effort to dumb-down CS?
Api the Baboon:  Dumb-down?  Impossible!  We're going to JAVA!  We're
                 scaling the very summit of High Technology!
Monkey 347:      I rest my case.

        -- from "The Adventures of Code Monkey #347"