Subject: Re: egcs 1.1 on pmax
To: Todd Vierling <>
From: Tsubai Masanari <>
List: tech-toolchain
Date: 08/20/1998 16:14:43
>Can you try building egcs with only the "#undef OBJECT_FORMAT_COFF" and the

I compiled egcs without DWARF... and ASM... macros and tried to make libstdc++
in old egcs-1.0.2 based src/gnu tree.  I got many warnings:

c++ -O -fPIC -DPIC -DABICALLS -Werror -nostdinc++  -I. -I/a/src/gnu/lib/libstdc
++/../../dist/libstdc++ -I/a/src/gnu/lib/libstdc++/../../dist/libio  -I/a/src/g
nu/lib/libstdc++/../../dist/libstdc++/stl -I/a/src/gnu/lib/libstdc++/../../dist
/gcc/cp/inc -c /a/src/gnu/lib/libstdc++/../../dist/libio/
/tmp/ccT54xmU.s: Assembler messages:
/tmp/ccT54xmU.s:1557: Warning: Tried to set unrecognized symbol: $LLCIE1,$LECIE

/tmp/ccT54xmU.s:1582: Warning: Tried to set unrecognized symbol: $LLFDE1,$LEFDE

and core dump:

building shared stdc++ library (version 1.0)
ld -x -shared -soname -o    --whole-archive lib
stdc++_pic.a --no-whole-archive /usr/lib/c++rt0.o  
*** Signal 6


With the two macros, I can compile libstdc++ successfully (small fixes
are needed though).

Doesn't occur on pmax?  binutils bug?