Subject: Re: A tag to check out i386 1.6 + MP
To: Frank van der Linden <>
From: D.J. Rudie <>
List: tech-smp
Date: 07/19/2002 07:30:49
Quoting Frank van der Linden <>:

> Since the question on how to check out the i386 MP code often
> comes up, I thought I'd add a CVS tag so that a stable system
> consisting of the 1.6 branch code and the i386 MP code can
> be checked out easily.
> To get NetBSD 1.6 (BETA* or RC*) with i386 MP:
> 	* check out syssrc using -r netbsd-1-6
> 	* cd syssrc/sys/arch/i386
> 	* cvs update using -r i386mp_plus16_stable
> Please note that this is just something I added as a convenience,
> the i386MP code is not part of NetBSD 1.6, and this tag is
> 'not officially supported', i.e. not guaranteed to create
> a compilable tree in the future (though it'll probably work
> for a while unless major changes occur on the 1.6 branch).
> But, since this will give you the codebase that, for example,
> the NetBSD crossbuild machine (dual Athlon with 2G of mem)
> has been running for a month now, with a constant load of
> 4.5 or higher, I thought it might be a good service to
> people to add it.
> - Frank
> -- 
> Frank van der Linden                                   
> ==============================================================================
> Quality NetBSD Development, Support & Service.  

i did exactly this
running netbsd 1.6_beta4
i checked out the latest syssrc
then i checked out mp update

i compiled a mp kernel
it loads fine
then in less than five minutes it hangs solid, no kernel panic or anything
just a solid freeze

i tried the i386mp branch a long time ago on 1.5y-current... it worked fine
then, except i would kernel panic every 3 to 4 days

now it doesnt even kernel panic, it just freezes solid

my motherboard is either an abit bp6 or a vp6 (i have both motherboards, not
sure which one is in there right now) and two celeron 550's


i'm not booted under an mp kernel rightnow, but here is my dmesg...

NetBSD 1.6_BETA4 (INEXISTENT) #0: Thu Jul  4 10:06:10 PDT 2002
cpu0: Intel Celeron (Mendocino) (686-class), 551.27 MHz
cpu0: I-cache 16 KB 32b/line 4-way, D-cache 16 KB 32b/line 2-way
cpu0: L2 cache 128 KB 32b/line 4-way
cpu0: features 183fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
cpu0: features 183fbff<PGE,MCA,CMOV,FGPAT,PSE36,MMX>
cpu0: features 183fbff<FXSR>
total memory = 255 MB
avail memory = 235 MB
using 3297 buffers containing 13188 KB of memory
BIOS32 rev. 0 found at 0xfb590
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
Intel 82443BX Host Bridge/Controller (host bridge, revision 0x03) at pci0 dev 0
function 0 not configured
ppb0 at pci0 dev 1 function 0: Intel 82443BX AGP Interface (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga0 at pci1 dev 0 function 0: ATI Technologies Rage 128 4x AGP 4x (rev. 0x00)
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
wsmux1: connecting to wsdisplay0
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371AB PCI-to-ISA Bridge (PIIX4) (rev. 0x02)
pciide0 at pci0 dev 7 function 1: Intel 82371AB IDE controller (PIIX4) (rev. 0x01)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <Maxtor 91536U6>
wd0: drive supports 16-sector PIO transfers, LBA addressing
wd0: 14648 MB, 16383 cyl, 16 head, 63 sec, 512 bytes/sect x 30000096 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 4 (Ultra/66)
pciide0: primary channel interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data
pciide0: secondary channel wired to compatibility mode
atapibus0 at pciide0 channel 1: 2 targets
cd0 at atapibus0 drive 1: <CD-ROM 24X/AKOx, , 16B1> type 5 cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2
pciide0: secondary channel interrupting at irq 15
cd0(pciide0:1:1): using PIO mode 4, DMA mode 2 (using DMA data transfers)
Intel 82371AB USB Host Controller (PIIX4) (USB serial bus, revision 0x01) at
pci0 dev 7 function 2 not configured
Intel 82371AB Power Management Controller (PIIX4) (miscellaneous bridge,
revision 0x02) at pci0 dev 7 function 3 not configured
rtk0 at pci0 dev 11 function 0: RealTek 8139 10/100BaseTX
rtk0: interrupting at irq 11
rtk0: Ethernet address 00:50:ba:d3:d6:cb
ukphy0 at rtk0 phy 7: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000000, model 0x0000, rev. 0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pciide1 at pci0 dev 19 function 0: Triones/Highpoint HPT366 IDE Controller
pciide1: bus-master DMA support present
pciide1: primary channel wired to native-PCI mode
pciide1: using irq 11 for native-PCI interrupt
pciide2 at pci0 dev 19 function 1: Triones/Highpoint HPT366 IDE Controller
pciide2: bus-master DMA support present
pciide2: primary channel wired to native-PCI mode
pciide2: using irq 11 for native-PCI interrupt
isa0 at pcib0
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
biomask eff5 netmask eff5 ttymask fff7
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
IP Filter: v3.4.27 initialized.  Default = pass all, Logging = enabled
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)
Accounting started

This mail sent through IMP: