Subject: MP Kernel boot test - SuperMicro P6DNE board, Dell 2450 Server
To: None <,>
From: Paul J. Lavoie <>
List: tech-smp
Date: 03/20/2000 17:46:55
A couple of tests I managed to do with some multi-processor systems:

Dell 2450:

Failed to load on a dual-processor system. Received the following message 
after the load was complete:

panic: vm_page_physget: called _after_ bootstrap

This is with a Dell 2450 w/ 2 733-MHz Processors w/ 1GB of memory. The floppy 
set worked with a single processor on the motherboard.

SuperMicro P6DNE board

Somewhat older, this mostly worked - recognized the CPUs, but could not 
initialize the second CPU, it would seem...

The kernel message buffer follows.


NetBSD 1.4T (INSTALL.MP) #5: Tue Feb 29 09:45:16 EST 2000
total memory = 127 MB
avail memory = 112 MB
using 1659 buffers containing 6636 KB of memory
biostramp installed @ 1000
BIOS32 rev. 0 found at 0xfdb80
mainbus0 (root)
mainbus0: scanning 0x9fc00 to 0x9fff0 for MP signature
mainbus0: scanning 0x9f800 to 0x9fbf0 for MP signature
mainbus0: scanning 0xf0000 to 0xffff0 for MP signature
mainbus0: MP floating pointer found in bios at 0xfb860
mainbus0: MP config table at 0xf7be0, 252 bytes long
mainbus0: Intel MP Specification (Version 1.4)
mainbus0: MP OEM INTEL    Product 440FX       
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: family 6 model 3 step 2
cpu0: Intel OverDrive Pentium II (Klamath) (686-class)
cpu0: features 183fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
cpu0: features 183fbff<PGE,MCA,CMOV,FGPAT,PSE36,MMX,FXSR>
cpu0: calibrating local timer
cpu0: apic clock running at 66 MHz
cpu0: kstack at 0xc9af8000 for 8192 bytes
cpu0: idle pcb at 0xc9af8000, idle sp at 0xc9af9fa0
cpu1 at mainbus0: apid 1 (application processor)
cpu1: family 6 model 3 step 2
cpu1: Intel OverDrive Pentium II (Klamath) (686-class)
cpu1: features 183fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
cpu1: features 183fbff<PGE,MCA,CMOV,FGPAT,PSE36,MMX,FXSR>
cpu1: kstack at 0xc9afa000 for 8192 bytes
cpu1: idle pcb at 0xc9afa000, idle sp at 0xc9afbfa0
ioapic0 at mainbus0 apid 2 (I/O APIC)
ioapic0: pa 0xfec00000, virtual wire mode, version 11, 24 pins
ioapic0: int0 attached to ExtINT (type 3<type=3=ExtINT> flags 0<pol=0,trig=0>)
ioapic0: int1 attached to isa0 irq 1 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int2 attached to isa0 irq 0 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int3 attached to isa0 irq 3 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int4 attached to isa0 irq 4 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int5 attached to isa0 irq 5 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int6 attached to isa0 irq 6 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int7 attached to isa0 irq 7 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int8 attached to isa0 irq 8 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int12 attached to isa0 irq 12 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int13 attached to isa0 irq 13 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int14 attached to isa0 irq 14 (type 0<type=0> flags 0<pol=0,trig=0>)
ioapic0: int16 attached to isa0 irq 11 (type 0<type=0> flags f<pol=3=Act 
ioapic0: int17 attached to isa0 irq 15 (type 0<type=0> flags f<pol=3=Act 
ioapic0: int18 attached to isa0 irq 9 (type 0<type=0> flags f<pol=3=Act 
ioapic0: int19 attached to isa0 irq 10 (type 0<type=0> flags f<pol=3=Act 
local apic: int0 attached to ExtINT (type 3<type=3=ExtINT> flags 
local apic: int1 attached to NMI (type 1<type=1=NMI> flags 0<pol=0,trig=0>)
mainbus0: MP WARNING: 8 bytes of extended entries not examined
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x8086 product 0x1237 (rev. 0x02)
pcib0 at pci0 dev 7 function 0
pcib0: vendor 0x8086 product 0x7000 (rev. 0x01)
pciide0 at pci0 dev 7 function 1: Intel 82371SB IDE Interface (PIIX3)
pciide0: device disabled (at device)
vendor 0x8086 product 0x7020 (USB serial bus, revision 0x01) at pci0 dev 7 
function 2 not configured
vendor 0x5333 product 0x883d (VGA display, revision 0x02) at pci0 dev 17 
function 0 not configured
ahc1 at pci0 dev 18 function 0
pci_intr_map: no MP mapping found
ahc1: interrupting at irq 15
ahc1: Reading SEEPROM...done.
ahc1: aic7870 Single Channel, SCSI Id=7, 16 SCBs
ahc1: Downloading Sequencer Program...Done
scsibus0 at ahc1 channel 0: 8 targets, 8 luns per target
de0 at pci0 dev 19 function 0
pci_intr_map: no MP mapping found
de0: interrupting at irq 9
de0: SMC 21041 [10Mb/s] pass 1.1
de0: address 00:00:c0:90:91:e4
de0: supplying EUI64: 00:00:c0:ff:fe:90:91:e4
ahc2 at pci0 dev 20 function 0
pci_intr_map: no MP mapping found
ahc2: interrupting at irq 10
ahc2: Reading SEEPROM...done.
ahc2: aic7870 Single Channel, SCSI Id=7, 16 SCBs
ahc2: Downloading Sequencer Program...Done
scsibus1 at ahc2 channel 0: 8 targets, 8 luns per target
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
seaprobe: board type unknown at address 0xc8000
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
pc0 at isa0 port 0x60-0x6f irq 1: color
pc0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: no ISA Plug 'n Play devices found
biomask 0 netmask 0 ttymask 0
cpu0: prelint0 700<vector=0,delmode=7,dest=0> 0<target=0>
cpu0: prelint1 400<vector=0,delmode=4,dest=0> 0<target=0>
cpu0: timer0 300d0<vector=d0,delmode=0,masked,dest=0> 0<target=0>
cpu0: pcint0 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
cpu0: lint0 10700<vector=0,delmode=7,masked,dest=0> 0<target=0>
cpu0: lint1 400<vector=0,delmode=4,dest=0> 0<target=0>
cpu0: err0 1000f<vector=f,delmode=0,masked,dest=0> 0<target=0>
ioapic0: enabling
ioapic0: int0 10700<vector=0,delmode=7,masked,dest=0> 0<target=0>
ioapic0: int1 1a0<vector=a0,delmode=1,dest=0> 0<target=0>
ioapic0: int2 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int3 1e1<vector=e1,delmode=1,dest=0> 0<target=0>
ioapic0: int4 1e2<vector=e2,delmode=1,dest=0> 0<target=0>
ioapic0: int5 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int6 170<vector=70,delmode=1,dest=0> 0<target=0>
ioapic0: int7 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int8 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int9 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int10 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int11 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int12 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int13 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int14 10100<vector=0,delmode=1,masked,dest=0> 0<target=0>
ioapic0: int15 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int16 1a100<vector=0,delmode=1,actlo,level,masked,dest=0> 0<target=0>
ioapic0: int17 a171<vector=71,delmode=1,actlo,level,dest=0> 0<target=0>
ioapic0: int18 f181<vector=81,delmode=1,pending,actlo,irrpending,level,dest=0> 
ioapic0: int19 a172<vector=72,delmode=1,actlo,level,dest=0> 0<target=0>
ioapic0: int20 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int21 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int22 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
ioapic0: int23 10000<vector=0,delmode=0,masked,dest=0> 0<target=0>
de0: enabling 10baseT port
scsibus0: waiting 2 seconds for devices to settle...
ahc1: target 1 synchronous at 10.0MHz, offset = 0xf
sd0 at scsibus0 targ 1 lun 0: <SEAGATE, ST52160N, 0285> SCSI2 0/direct fixed
sd0: 2069 MB, 6536 cyl, 4 head, 162 sec, 512 bytes/sect x 4238282 sectors
ahc1: target 3 synchronous at 10.0MHz, offset = 0xf
sd1 at scsibus0 targ 3 lun 0: <SEAGATE, ST52160N, 0285> SCSI2 0/direct fixed
sd1: 2069 MB, 6536 cyl, 4 head, 162 sec, 512 bytes/sect x 4238282 sectors
ahc1: target 5 synchronous at 6.67MHz, offset = 0xf
st0 at scsibus0 targ 5 lun 0: <ARCHIVE, Python 25501-XXX, 6280> SCSI2 
1/sequential removable
st0: drive empty
ahc1: target 6 synchronous at 4.0MHz, offset = 0xf
cd0 at scsibus0 targ 6 lun 0: <TOSHIBA, CD-ROM XM-5401TA, 3605> SCSI2 5/cdrom 
scsibus1: waiting 2 seconds for devices to settle...
ahc2: target 0 synchronous at 10.0MHz, offset = 0xf
sd2 at scsibus1 targ 0 lun 0: <SEAGATE, ST34520N, 1281> SCSI2 0/direct fixed
sd2: 4340 MB, 9006 cyl, 4 head, 246 sec, 512 bytes/sect x 8888924 sectors
md0: internal 1587K image area
boot device: fd0
root on md0a dumps on md0b
mountroot: trying msdos...
mountroot: trying cd9660...
mountroot: trying ntfs...
mountroot: trying nfs...
mountroot: trying ext2fs...
mountroot: trying ffs...
root file system type: ffs
cpu1: starting
cpu1: init idle stack ptr is 0xc9afbfa0
cpu failed to become ready
init: copying out flags `-s' 3
init: copying out path `/sbin/init' 11
fd0d: hard error reading fsbn 0 (st0 40<abnrml> st1 1<no_am> st2 0 cyl 0 head 
0 sec 1)
fd0d: hard error reading fsbn 1 (st0 40<abnrml> st1 1<no_am> st2 0 cyl 0 head 
0 sec 2)
<7>de0: starting DAD for fe80:0001::0200:c0ff:fe90:91e4
<6>de0: DAD complete for fe80:0001::0200:c0ff:fe90:91e4 - no duplicates found

Paul J. Lavoie		(212) 510-3029
ILX Systems, Inc.	111 Fulton St		New York, NY  10038