Subject: Foward: [OpenSSL Advisory] Vulnerabilities in ASN.1 parsing
To: None <>
From: Takahiro Kambe <>
List: tech-security
Date: 09/30/2003 23:35:15
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit


Takahiro Kambe <>

Content-Type: Message/Rfc822
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

	id 0E02C120363; Tue, 30 Sep 2003 23:33:47 +0900 (JST)
	by (Postfix) with ESMTP id 100A012031D
	for <>; Tue, 30 Sep 2003 23:33:43 +0900 (JST)
	id E78BB1936B; Tue, 30 Sep 2003 16:32:46 +0200 (CEST)
	by (Postfix) with ESMTP id C045119323
	for <>; Tue, 30 Sep 2003 16:32:46 +0200 (CEST)
	id 35E3927F66A; Tue, 30 Sep 2003 16:32:47 +0200 (CEST)
	id 2387B27F65C; Tue, 30 Sep 2003 16:32:47 +0200 (CEST)
	id CD76E27F622; Tue, 30 Sep 2003 16:32:46 +0200 (CEST)
	by (Postfix) with ESMTP
	id 6BD5C27F608; Tue, 30 Sep 2003 16:05:40 +0200 (CEST)
	by with esmtp (Exim 4.20)
	id 1A4LTi-0002Ac-Ot; Tue, 30 Sep 2003 15:27:50 +0100
Date: Tue, 30 Sep 2003 15:27:50 +0100 (BST)
From: Mark J Cox <>
To:, <>,
Subject: [OpenSSL Advisory] Vulnerabilities in ASN.1 parsing
In-Reply-To: <>
Message-ID: <>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Mime-Version: 1.0 (modified by Mew)


OpenSSL Security Advisory [30 September 2003]

Vulnerabilities in ASN.1 parsing

NISCC ( prepared a test suite to check the operation
of SSL/TLS software when presented with a wide range of malformed client

Dr Stephen Henson ( of the OpenSSL core team
identified and prepared fixes for a number of vulnerabilities in the
OpenSSL ASN1 code when running the test suite.

A bug in OpenSSLs SSL/TLS protocol was also identified which causes
OpenSSL to parse a client certificate from an SSL/TLS client when it
should reject it as a protocol error.

- ---------------

1. Certain ASN.1 encodings that are rejected as invalid by the parser
can trigger a bug in the deallocation of the corresponding data
structure, corrupting the stack. This can be used as a denial of service
attack. It is currently unknown whether this can be exploited to run
malicious code. This issue does not affect OpenSSL 0.9.6.

2. Unusual ASN.1 tag values can cause an out of bounds read under
certain circumstances, resulting in a denial of service vulnerability.

3. A malformed public key in a certificate will crash the verify code if
it is set to ignore public key decoding errors. Public key decode errors
are not normally ignored, except for debugging purposes, so this is
unlikely to affect production code. Exploitation of an affected
application would result in a denial of service vulnerability.

4. Due to an error in the SSL/TLS protocol handling, a server will parse
a client certificate when one is not specifically requested. This by
itself is not strictly speaking a vulnerability but it does mean that
*all* SSL/TLS servers that use OpenSSL can be attacked using
vulnerabilities 1, 2 and 3 even if they don't enable client authentication.

Who is affected?
- ----------------

All versions of OpenSSL up to and including 0.9.6j and 0.9.7b and all
versions of SSLeay are affected.

Any application that makes use of OpenSSL's ASN1 library to parse
untrusted data. This includes all SSL or TLS applications, those using
S/MIME (PKCS#7) or certificate generation routines.

- ---------------

Upgrade to OpenSSL 0.9.7c or 0.9.6k. Recompile any OpenSSL applications
statically linked to OpenSSL libraries.

- ----------

The Common Vulnerabilities and Exposures project ( has
assigned the name CAN-2003-0545 for issue 1:

and CAN-2003-0543 and CAN-2003-0544 for issue 2:

URL for this Security Advisory:
Version: GnuPG v1.2.1 (GNU/Linux)


OpenSSL Project                       
Announcement Mailing List       
Automated List Manager