Subject: Re: OpenSSH installation from package source
To: Rick Byers <>
From: Johnny C. Lam <>
List: tech-security
Date: 07/01/2002 10:39:35
On Mon, Jul 01, 2002 at 09:28:05AM -0400, Rick Byers wrote:
> I believe its not intended for NetBSD 1.5+ users to install the openssh
> package since openssh is part of the base OS.  Instead of installing the
> package, you could update your sources to the latest NetBSD-1.5-release.
> I don't think the package should be installing anywhere other than
> /usr/pkg.

Actually, the security/openssh package has been modified so that you can
optionally directly replace the openssh in the base system.  This can be
done by adding


to your /etc/mk.conf and building and installing from a current pkgsrc.
You may want to back up your old ssh files first before doing this update,
just in case it doesn't work (although I've tested updating on both
NetBSD 1.5.x and on NetBSD-1.6_BETA*).


	-- Johnny Lam <>