Subject: Re: pkgsrc/security/openssl fails to build on NetBSD 1.4/alpha
To: Simon Burge <>
From: None <>
List: tech-security
Date: 08/25/1999 00:08:22
>> 	Hello,
>> 	Is anyone using NetBSD-1.4 pkgsrc/security/openssl on NetBSD 1.4/alpha,
>> 	without RSAREF (USE_RSAREF=NO)?
>> 	for me, it compiles just fine on NetBSD 1.4/i386, but not on alpha.  
>> 	It fails like attached.
>If I get rid of references to RSAglue then I get something that builds
>fine.  Also, linking against libcrypto.a (instead of -L.. -lcrypto)
>works.  It looks like the ELF toolchain has problems because it can't
>resolve the symbols listed below even though nothing calls them.
>Does the following break the USE_RSAREF2=yes case (which I obviously
>can't test, but I suspect so :-)?

	This did the trick for me on NetBSD14/alpha (for USE_RSAREF=NO).
	Thanks very much!  Hope someone in US can confirm USE_RSAREF=YES case.