tech-repository archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Issues with the git server

Hello Joerg,

For the first time ever (and finally!) I decided to try your Git
mirror of the src repository and, along the way, I experienced a bunch
of issues.

First, when I attempted a clone yesterday, the operation failed
halfway through saying that a particular object from the repository
was corrupted.  (It may just be that I ran out of disk space in this
case though.)  I tried again afterwards and the clone finished

But today (a mere ~12h after the original clone, and without having
done any edits to the tree at all), I did a "git pull" and the merge
failed due to conflicts.  The output was:

# Changes to be committed:
#       modified:   external/gpl3/binutils/dist/bfd/elf32-vax.c
#       modified:   external/gpl3/binutils/dist/gas/config/tc-vax.c
#       new file:   sys/arch/powerpc/include/mpc8xx/spr.h
# Unmerged paths:
#   (use "git add/rm <file>..." as appropriate to mark resolution)
#       both modified:      sys/dev/sdmmc/sdhc.c
#       both modified:      sys/dev/sun/cgsix.c
#       both modified:      sys/net/if_ethersubr.c
#       both added:         usr.sbin/npf/npfctl/npf_disassemble.c

Upon inspecting the files with conflicts, most of them were due to
$NetBSD$ changes.  But other regular changes also caused conflicts, so
it seems as if none of the changes to these files could be merged
successfully... which seems strange.

Any ideas about what might have caused this?  I'm assuming that
$NetBSD$ tag changes should not cause any kind of problems...


PS: Now giving a try to the fossil clone, but it's very slow...

Home | Main Index | Thread Index | Old Index