tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems with distcc on earmv4


I run distcc for pkgsrc on many architectures: VAX, m68k sparc, sparc64, SuperH, mipsel, mips64eb, earm (v5), aarch64eb. I've only ever had a problem trying to run it on Alpha, but that appeared to be a distcc problem, not anything related to pkgsrc.

For some reason I'm seeing issues with earmv4 specifically. I'm using the exact same setup as other machines (just changing the port number for the corresponding distcc for earmv4), on a new system with no local changes.

Here, as an example, I'm trying to build benchmark/flops. This doesn't even use distcc because it compiles and links at the same time (which distcc doesn't handle), so there's no reson this shouldn't work:

===> build-message [flops-2.0] ===> Building for flops-2.0
(cd /usr/pkgsrc/benchmarks/flops/work ; gcc -O2 -fPIC -D_FORTIFY_SOURCE=2 -DUNIX -o flops flops.c -lm) distcc[6836] (dcc_trace_version) distcc 3.4 armv4--netbsdelf-eabi; built Mar 4 2023 17:55:57
distcc[6836] (dcc_recursion_safeguard) safeguard level=0
distcc[6836] (main) compiler name is "gcc"
distcc[6836] (dcc_set_path) setting PATH=/usr/pkgsrc/benchmarks/flops/work/.gcc/bin:/usr/pkgsrc/benchmarks/flops/work/.tools/bin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/pkg/sbin:/usr/pkg/bin:/usr/X11R7/bin:/usr/local/sbin:/usr/local/bin distcc[6836] (dcc_scan_args) scanning arguments: gcc -fcommon -O2 -fPIC -D_FORTIFY_SOURCE=2 -DUNIX -o flops flops.c -lm -fPIC -D_FORTIFY_SOURCE=2 -fstack-protector-strong -I/usr/pkgsrc/benchmarks/flops/work/.buildlink/include -pie
distcc[6836] (dcc_scan_args) found object/output file "flops"
distcc[6836] (dcc_scan_args) found input file "flops.c"
distcc[6836] (dcc_scan_args) compiler apparently called not for compile
distcc[6836] (dcc_get_hostlist) read hosts from environment
distcc[6836] (dcc_parse_hosts) found tcp token ""
distcc[6836] (dcc_lock_host) got cpu lock on localhost slot 0 as fd3
distcc[6836] exec on localhost: gcc -fcommon -O2 -fPIC c -DUNIX -o flops flops.c -lm -fPIC -D_FORTIFY_SOURCE=2 -fstack-protector-strong -I/usr/pkgsrc/benchmarks/flops/work/.buildlink/include -pie distcc[6836] (dcc_note_state) note state 5, file "flops.c", host "localhost" distcc[6836] (dcc_spawn_child) forking to execute: gcc -fcommon -O2 -fPIC c -DUNIX -o flops flops.c -lm -fPIC -D_FORTIFY_SOURCE=2 -fstack-protector-strong -I/usr/pkgsrc/benchmarks/flops/work/.buildlink/include -pie
distcc[6836] (dcc_spawn_child) child started as pid14002
distcc[14002] (dcc_increment_safeguard) setting safeguard: _DISTCC_SAFEGUARD=1
gcc: error: c: No such file or directory
distcc[6836] (dcc_collect_child) cc child 14002 terminated with status 0x100 distcc[6836] (dcc_collect_child) cc times: user 0.000000s, system 0.000000s, 0 minflt, 0 majflt
distcc[6836] ERROR: compile flops.c on localhost failed
distcc[6836] (dcc_unlock) release lock fd3
distcc[6836] elapsed compilation time 0.185166s
distcc[6836] (dcc_exit) exit: code 1; self: 0.036542 user 0.091355 sys; children: 0.028411 user 0.085233 sys
distcc[6836] (dcc_cleanup_tempfiles_inner) deleted 0 temporary files
*** Error code 1


.for DISTCCDEPS in sysutils/checkperms pkgtools/digest devel/distcc devel/popt devel/libtool-base devel/gmake devel/m4 pkgtools/cwrappers pkgtools/mktools
.if !defined(IGNORE_DISTCC)
  PKGSRC_COMPILER=distcc gcc

Where is "gcc: error: c: No such file or directory" coming from? Any ideas, or any thoughts about what to check? Why would earmv4 be any different?

This is a system running NetBSD 10.0_BETA from 4-March-2023 sources. I didn't get details then, but when I tried getting distcc working on the NetBSD-9 earmv4 system I'm using to build pkgsrc binary packages, it didn't work there, either, and I'm imagining the reasoning is likely the same.


Home | Main Index | Thread Index | Old Index