[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: [meiwaku] binary pkg "variants" ?
Fredrik Pettai wrote:
| I noticed the way MacPorts done it and it looks reasonable ok. They name the
| package "variants" as: pkgname @version+option(s). Perhaps pkgsrc could name
| those alternative bin pkgs as: pkgname+option(s)-version ?
Anthony Mallet wrote:
| I also did that in robotpkg (http://robotpkg.openrobots.org)
| Binary packages are named according to the following scheme:
| $PKG_OPTIONS are joined with the "+" char.
| Patches 1 & 2 are just code refactoring, patch 3 implements the real stuff.
| There is my git commit message in the patch, hopefully explaining what is
On Tuesday, at 13:22, Ryo ONODERA wrote:
| Another freeze has started...
| What is the stopper of this change.
| If there is no stopper, please commit just after freeze end.
Last time this was discussed, I more or less understood the conclusions as:
- This functionality is not really needed
- The efficiency of my proposed implementation is questionable (scalability,
Which are both valid points. Here is the thread:
But I'm ready to discuss this again :)
Main Index |
Thread Index |