tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 2013Q3 freeze pre-announcement

Joerg Sonnenberger <> writes:

> I think it is time again to prune some PostgreSQL versions. So I would
> like to kill 8.4 and 9.0 now and change the default version to 9.2.

No objections to changing the default to 9.2, but I think we should be
asking the MAINTAINER of the postgresql packages.

Again, I think the issue for removing packages is what best serves the
interests of users.  Updating postgres across branches is a pain, and
8.4 and 9.0 are both still supported by  My usual
question is whether we can say to someone who is running 8.4: "It's lame
that you haven't updated yet, so you're out of luck."  I'm not super
plugged in to postgresql culture, but I don't think we're there yet.  On
the site, they say that 1) 8.4 is EOL in July of 2014 and
2) it's recommended to update to the latest point release of the branch
you are running.  See

I don't see a lot of maintenance hassle in the older postgresql
versions.  Looking at postgresql84/Makefile.common, I see a 2-line
update a few times a year that has that "update version and regen
distinfo" look about it.  I expect that changes to the 8.4 branch (and
all branches older than 9.2, maybe even 9.2) will be bugfixes only.  If
the person doing the updates wants to do it, I don't think it's
reasonable to object.  If people on pkgsrc-releng@ want to speak up and
object, I think we should listen, but I haven't heard that.

Plus, I see adam@ as MAINTAINER and the one doing the updates, so I
don't think it's reasonable for other people to remove these packages.
(If adam@ thought it was time to remove them, I'd be very inclined to
accept his judgement as maintainer.)

Attachment: pgpJiOnHlSCNz.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index