tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Circular dependency errors

On Thu, 08 Aug 2013 11:43:49 +0900, Paul Ackersviller <> 

On Wed, Aug 07, 2013 at 02:29:05PM +0900, OBATA Akio wrote:
I might overlooked your reports, but circular dependency must not exist.
If it will be found, then it must be resolved.

I never reported any of these recently, but in a newly bootstrapped 2013Q2
I'm getting this between pkgtools/digest and lang/perl5.  I'm getting
around it simply by setting TOOLS_PLATFORM.perl to an existing perl.

Hmm, lang/perl requires pkgtools/digest to build, but
pkgtools/digest should not require any packages (including lang/perl).

Could you provide whole circular dependency chain?

OBATA Akio /

Home | Main Index | Thread Index | Old Index