tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PREFER_PKGSRC with exceptions

On Thu, 2013-03-28 at 13:50 +0000, Emmanuel Dreyfus wrote:
> Hi
> I would like to build dataabses/php-ldap using pkgsrc's OpenLDAP, while
> security/pam-ldap would use built-in OpenLDAP. Such syntax seems 
> unsupported:
> PREFER_PKGSRC=openldap
> PREFER_NATIVE.pam-ldap=openldap
> Is there anyther ay to do it?

Two different LOCALBASEs?

It seems dangerous to me to try and support mixing the source of a
library between packages generally - eventually a package would be in
the position of depending on and using both concurrently...

Home | Main Index | Thread Index | Old Index