tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: poppler for 6.0 amd64 uses pkgsrc fontconfig instead of /usr/X11R7

On Thu, 29 Nov 2012, Jeremy C. Reed wrote:

> Anyone know why the poppler package for the amd64 6.0 builds (available 
> on the FTP server) uses the pkgsrc fontconfig instead of the fontconfig 
> in /usr/X11R7?
> Dependency is 2.8.0nb2, the X11R7 version is 2.8.0. When I build it, it 
> uses the /usr/X11R7 version.
> (The builder information, like BUILD_HOST, never got integrated into 
> pkg_summary yet, so I am not sure who built it.)

:)  I simply looked in the files...

The fontconfig's +CONTENTS has:

  @pkgdep fontconfig>=2.8.0nb2

and +BUILD_INFO has:

  BUILD_DATE=2012-11-06 12:23:41 +0000
  BUILD_HOST=NetBSD amd64-nb6 6.0 NetBSD 6.0 (LIBKVER) #0: Tue Jan 19 
  00:00:00 UTC 2038 root@localhost:/sys/arch/amd64/compile/LIBKVER amd64

Any ideas why the /usr/X11R7 fontconfig was not used?


Home | Main Index | Thread Index | Old Index