tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: postgresql packages, PG_SUBPREFIX and CONFLICTS

On Wed, Oct 24, 2012 at 3:23 AM, Aleksej Saushev <> 
> Aleksey Cheusov <> writes:
>> Personally, I don't have anything
>> against avoiding CONFLICTS in this case but I'm not willing to do this
>> myself. So, unless anyone do this, I'd like to completely remove
>> PG_SUBPREFIX and keep CONFLICTS up-to-date.
> I strongly object to this. Whoever removed PG_SUBPREFIX was wrong,
> this is the feature that is rather frequently needed in practice.

If you object, please go ahead and avoid conflicts between
postgresql packages. Until you do this CONFLICTS should work as
it *is* documented.

> CONFLICTS, on contrary, is _never_ needed. pkg_add handles this very well.

Repeating your opinion twice doesn't add any value to the discussion.
I already answered why CONFLICTS is needed. Please reread my emails.

> Currently you're trying to introduce information that is better
> maintained automatically.

No, see my answers to Joerg.

Home | Main Index | Thread Index | Old Index