tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Fixing xproto


How does one fix this for good? It doesn't matter if the latest xproto from pkgsrc is installed - it seems that x11/xkbcomp only cares about what's in the base system (netbsd-5 from May, which is relatively recent).

John Klos

checking for strcasecmp... yes
checking for XKBCOMP... configure: error: Package requirements (x11 xkbfile xproto >= 7.0.17) were not met:

Requested 'xproto >= 7.0.17' but version of Xproto is 7.0.15

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XKBCOMP_CFLAGS
and XKBCOMP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

Home | Main Index | Thread Index | Old Index