tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Pkgsrc/../gtk3 brak with XInput2.h


On Tue, 22 May 2012 22:09:10 +0900, Maurizio Caloro <> 

For Brassero i need GTK3 now try to compile GTK3 but i have the error message 
file XInput.h are not available?

File are here /usr/pkg/include/X11/extensions/XInput2.h

for me opinion the file exist. i try also to add the hole Path from XInput2.h to and configure but this had no succsess. The switch options 
"--Disable-xinput" also give me no success.
possible any help ?

gtk+3.4.x require XInput2 extension.
Builtin libXi on NetBSD-5.1 is 1.2.1, but libXi>=1.3 is required for Xinput2 

Require followings?
1. Add BUILDLINK_API_DEPENDS.libXi+= libXi>=1.3 in x11/gtk3/ (and
2. Implement x11/libXi/ to detect builtin version (and change
3. Update pkgtools/x11-links to handle libXi?

OBATA Akio /

Home | Main Index | Thread Index | Old Index