tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44713, brokennes of GNU patch

On Fri, Dec 09, 2011 at 05:36:18PM +0300, Aleksey Cheusov wrote:
> Hello. GNU patch fails to apply pkgsrc patches correctly (see
>  Another problem is that latest versions
> of GNU patch exit with error if files to be modified are read-only. This
> happens very often with pkgsrc distfiles.
> In order to solve this problem I'd like to enable devel/nbpatch
> unconditionally during bootstrap on Linux and Solaris.
> Then close pkg/44713.

I do regular bulk builds on Solaris 10u9 and OpenIndiana. I don't
remember ever seeing any problem like this, using the gpatch provided by
the system.


%SYSTEM-F-ANARCHISM, The operating system has been overthrown

Home | Main Index | Thread Index | Old Index