tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USE_CMAKE in meta-pkgs/kde4/

Brook Milligan
<brook@viola.i-did-not-set--mail-host-address--so-tickle-me> writes:

> I am building a package that depends on kde4 and therefore should
> presumably include  That file defines many CMAKE_ARGS options,
> yet does not define USE_CMAKE.  It seems to me that it should in order
> to ensure that cmake is actually used.  As it currently stands,
> individual packages must do this each time.

Are you sure that every package that depends on kde4 uses cmake?  I
would think some don't, and thus CMAKE_ARGS is set to help those that
do, but to permit non-cmake packages.

If so, a comment explaining that is probably in order.

Attachment: pgpLLQkLE_543.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index