tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

adding a minimum ocaml compiler requirement to unison: how?


background: a while ago, I patched the native ARM backend of lang/ocaml
so that code generated by ocamlopt would not SIGILL on thumbless CPUs.

Now, I wanted to teach net/unison to use the native compiler also 
for arm. To make sure that only a sufficiently patched compiler is
used, I wanted it to depend on ocaml>=3.12.0nb2

lang/ocaml/ contains:

BUILDLINK_API_DEPENDS.ocaml+=   ocaml>=3.08.2
BUILDLINK_ABI_DEPENDS.ocaml+=   ocaml>=3.09.1nb2

I tried 


I tried 

BUILDLINK_ABI_DEPENDS.ocaml+=   ocaml>=3.12.0nb2

and even using BUILDLINK_API_DEPENDS.ocaml.

Whatever I do, make always results in

=> Build dependency ocaml>=3.09.1nb2: found ocaml-3.12.0nb2

That is, in a tree with a compiler that's too old it would nevertheless

So, what should I do?


Home | Main Index | Thread Index | Old Index