tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

GNU patch 2.5.8 (part of e.g. Mac OS 10.7.8) breaks "pkgsrc"


I've upgrade my Mac to OS 10.8.0 (latest version of Snow Leopard).
Now some packages fail to build:

=> Applying pkgsrc patches for xvidcore-1.2.2
/usr/bin/patch: **** rejecting file name with ".." component: ../../src/xvid.c
Patch /usr/pkgsrc/multimedia/xvidcore/patches/patch-ac failed
ERROR: Patching failed due to modified or broken patch file(s):
ERROR:  /usr/pkgsrc/multimedia/xvidcore/patches/patch-ac
*** Error code 1

bmake: stopped in /usr/pkgsrc/multimedia/xvidcore
*** Error code 1

This is apparently a security fix in GNU patch 2.5.8:

Any brilliant ideas what to do about it? Using "devel/patch" would work
around this problem for now until that package gets updated.

        Kind regards

Matthias Scheler                        

Home | Main Index | Thread Index | Old Index