tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

math/gnumeric110 has unnecessary dependencies

According to upstream's website, (at least) lib{bonobo{,ui},gnomeui}
and ORBit2 are not needed. Attached patch seems to work well for
me; no build- or run-time errors occur. It would be nice if someone
could double-check and/or commit this or something similar.


Dennis den Brok
Index: math/gnumeric110/Makefile
RCS file: /cvsroot/pkgsrc/math/gnumeric110/Makefile,v
retrieving revision 1.15
diff -u -r1.15 Makefile
--- math/gnumeric110/Makefile   14 Sep 2010 11:02:20 -0000      1.15
+++ math/gnumeric110/Makefile   7 Nov 2010 15:03:41 -0000
@@ -41,9 +41,6 @@
 BUILDLINK_API_DEPENDS.libgsf+= libgsf>=1.14.6
 .include "../../devel/libgsf/"
 .include "../../devel/GConf/"
-.include "../../devel/libgnomeui/"
-.include "../../devel/libbonobo/"
-.include "../../devel/libbonoboui/"
 .include "../../devel/gettext-lib/"
 .include "../../devel/libglade/"
 .include "../../devel/zlib/"
@@ -51,7 +48,6 @@
 .include "../../lang/perl5/"
 BUILDLINK_API_DEPENDS.goffice0.8+= goffice0.8-${GOFFICE_VERSION}{,nb*}
 .include "../../misc/goffice0.8/"
-.include "../../net/ORBit2/"
 .include "../../textproc/libxml2/"
 .include "../../mk/"
 BUILDLINK_API_DEPENDS.gtk2+=   gtk2+>=2.10.0

Home | Main Index | Thread Index | Old Index