tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Update of Ruby packages


I'm working on update Ruby packages including Ruby 1.9.2pl0 in these

o Ruby (1.8.7-p302)
o Ruby 1.9.2pl0 (1.9.2-p0)

(Handling of patchlevel in PKGNAME would change.)

Default of RUBY_VERSION_DEFAULT remains to 1.8 at this time.

Due to support of these two versions and chnages by 1.9, I need to
change some (or many) to ruby packge's framework, such as gem/rake
included in Ruby 1.9.

* PKGNAME would be prefixed with RUBY_PKGPREFIX in
  lang/ruby/ if PKGNAME isn't defined:


  This reduce a line in many ruby extension packages.

* Some packages would be changed their PKGNAME, adding RUBY_PKGPREFIX
  to coexists both binary packages for 1.8 and 1.9.  It dosen't always
  mean that these pacakge could installed at the same time, but keep
  the both binary packages.

* During importing Ruby 1.9.2 and related updates, many packages are
  update or added for better support of Ruby 1.9.  (Rails would be
  updated to 2.3.8.)

* Some ruby packages aren't work with Ruby 1.9.  These packages would
  be excplictly have a line in their Makefile:


  But temporary, some packages might mark Ruby 1.8 only because of:

        - Having build problem
        - Not build test yet.

  Or other built packages might be not work by incompatibility between
  Ruby 1.8.7 and 1.9.2, especially character encoding handling.

I'm plan to these work from 9th Sep now.

Best regards and good night.

Takahiro Kambe <>

Home | Main Index | Thread Index | Old Index