tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42907 Errors in REQUIRES/PROVIDES variables in pkg_summary(5)

Hi. Can anybody analyse PR/42907 and apply the proposed patch?  I
prepared it several months ago and since then I use modified pkgsrc
sources without any problem. All packages were fully rebuilt several
times and there were just 2 REQUIRES/PROVIDES inconsistencies in
8000+/-200 binary packages under Linux. For comparison, in
NetBSD/x86_64/5.0/2010Q2 binary repository available at there are 347 inconsistencies.  My patch is for all
ELF platforms including NetBSD of course.

I also changed Darwin section but I didn't test it.

More details are here:

Best regards, Aleksey Cheusov.

Home | Main Index | Thread Index | Old Index