tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

can I get a volunteer? (emulators/compat-50)

Release Engineering needs some help.

As you may know, NetBSD 5.1 is almost ready to release.  One of the remaining
stumbling blocks is that a couple of shared libraries in xorg have
undergone a major number bump between 5.0 and 5.1 - and therefore the
xorg-using ports (i386, amd64, sparc64, sgimips, shark and macppc, I think)
can't use any binaries built against 5.0 which link against the libraries
in question unless they have said libraries through having upgraded from
5.0, or the reason for this email, having installed a compatibility package
from pkgsrc.

Would someone be willing to whip up at least a rudimentary compat50 package
in the next week or so?  I looked at doing it myself (and I'll come
back to it eventually if nobody else does), but the logic was more complex
than I currently have time to dive into.

The libraries in question:


... though it would seem that sooner or later we'll need a full-blown
compat package for when 6.0 is released anyway.

If you think you'll have time to work on this - please shoot me a quick
note.  It will be very helpful to be able to point people who run into
this issue to a package which solves their problem.


Home | Main Index | Thread Index | Old Index