tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: updating COMPAT_LINUX for linux 2.6.x support (take 2)

On Wed 30 Jun 2010 at 08:57:44 -0700, Chuck Silvers wrote:
>    - the assembler apparently now uses a different opcode for reloading %gs
>      than it used to, so the check for this instruction in INTRFASTEXIT
>      being the cause of a kernel trap wasn't working.  I fixed the check
>      to match the current generated code.

Would it not be necessary for compatibility with older binaries (how
much older??) to check for both cases?

___ Olaf 'Rhialto' Seibert  -- There's no point being grown-up if you 
\X/ rhialto/at/    -- can't be childish sometimes. -The 4th Doctor

Home | Main Index | Thread Index | Old Index