tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: finer-grained overriding of checks in pkg_add (improved replace safety)

  IMHO changing the required version so short before NetBSD 5.1 will be
  released, which uses an older version, is not a good idea.

It's only required in the case of doing a make replace and having
DESTDIR enabled.  That won't trigger for normal users since USE_DESTDIR
is not the default.

Also, we already decoupled base pkg tools from what pkgsrc needs.  I
think people have argued that we shoudn't even have package tools in
base (I'm not arguing that, but it's a sane argument).

FWIW, I did "make replace package clean" in pkgtools/pkg_install, and it
updated painlessly.

Attachment: pgp7HpESxfHYs.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index