tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: updating COMPAT_LINUX for linux 2.6.x support.

On Mon, May 03, 2010 at 07:18:27PM +1000, matthew green wrote:
>    (2) what linux kernel version do we want to claim to be in uname?
>        it would be good for this to be at least as recent as the
>        kernel matching what we choose in (1).  but it would good to avoid
>        going too wild with this, to keep the amount of new emul code
>        that's needed to a minimum.
> i'd recommend 2.6.18 (or 2.6.9) as an initial baseline since those are
> commonly used for building (at least commercial) linux software.

from looking at the mapping of syscalls to versions,
2.6.18 seems like a reasonable choice, I'll go with that.


Home | Main Index | Thread Index | Old Index