tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

RE: Change request of devel/autoconf to use .tar.gz

Wrote David Holland:
> On Thu, Apr 29, 2010 at 09:28:29AM -0500, Larson, Timothy E. wrote:
>  > Does anyone know if xz _really really_ requires gcc >=3.4?
> I don't, but it shouldn't be that hard to try it and find out...
>  > I work with a number of older platforms, and I know for a fact
> that
>  > gcc 3.4 is not even a remote dream right now.  (On one, I'd be
>  > happy just to have 2.95.x working.)  That effectively means
> losing
>  > pkgsrc on them.
> Since I don't remember exactly which crazy platforms you've been
> working with :-)  are these CPUs no longer supported by newer gcc,
> which takes serious work, or just OS-related build issues, which are
> merely lengthy and tedious to patch up?

I don't remember for sure, but gcc dropped A/UX support at either 3.0 or 3.1.  
I'm using 2.7 there, because I haven't been able to find or successfully build 
anything newer.  On my AIX 4.1.5 system (powered down ATM) I think I have 
2.95.x.  I don't do all that much with AIX, so probably haven't tried even 
building a newer gcc there.  My IRIX and Solaris9 systems have gcc > 3.4 though.

Tim Larson
App Admin, Intercall Production Services

Home | Main Index | Thread Index | Old Index