tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

if API_DEPENDS not set causes pkg_info errors

I have noticed a few times that when a BUILDLINK_API_DEPENDS is not set in 
an included buildlink, it causes errors like:

=> Full dependency curl>=7.12.3: found curl-7.18.0
=> Full dependency gtkmm>=2.6.3: found gtkmm-2.12.3
pkg_info: missing package name(s)
usage: pkg_info [-BbcDdFfhIikLmNnpqRSsVvX] [-e package] [-E package]
                [-K pkg_dbdir] [-l prefix] pkg-name ...
       pkg_info [-a | -u] [flags]
       pkg_info [-Q variable] pkg-name ...
make: "../../mk/buildlink3/../../mk/buildlink3/" line 
323: warning: Couldn't read shell's output for "true Computing 
BUILDLINK_PREFIX.pangomm;                  /usr/pkg/sbin/pkg_info -K . -qp  
|      /usr/bin/sed  -e "s,^[^/]*,,;q""
===> Overriding tools for gimmage-0.2.3
===> Extracting for gimmage-0.2.3
===> Patching for gimmage-0.2.3
=> Applying pkgsrc patches for gimmage-0.2.3
===> Creating toolchain wrappers for gimmage-0.2.3
sh: Syntax error: expecting "in"
*** Error code 2

Home | Main Index | Thread Index | Old Index