tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: fam complexity

Greg Troxel wrote:
"Jared D. McNeill" <> writes:

On Mon, 16 Mar 2009, Greg Troxel wrote:
I ran pkg_rolling-replace on a machine which shouldn't have any gnome
goop on it (web server for trac which has graphviz).  It failed with:

===> Installing for libgamin-0.1.10
ERROR: libgamin-0.1.10 conflicts with installed package(s):
ERROR:     fam-2.7.0nb9
ERROR: They install the same files into the same place.
ERROR: Please remove conflicts first with pkg_delete(1).
*** Error code 1
I'm not sure why you think gamin/fam == GNOME. libgamin is a libfam

Fair enough, but it has in my experience come along for the ride.  I use
gnome on desktop machines, and was trying to keep my trac/svn server

I think my real beef is with upstream glib as it seems like something
which shouldn't have this sort of dependency.

Give me a break. If libgamin was part of glib you wouldn't have even noticed.

Home | Main Index | Thread Index | Old Index