tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Built-in OpenSSL and pkgsrc bootstrap?


what minimal version does the pkgsrc bootstrap require from the native OSes

An attempt to either build pkgtools/pkg_install on a previously
bootstrapped netbsd-1-5 machine, or re-bootstrap the machine, fails while
building pkg_install because of a missing <openssl/ui.h>. The openssl
version installed there is 0.9.6g. The missing header appeared in netbsd-2.

How does the pkgsrc bootstrap process know what to build (because platform
tools are not available, or not sufficient)?


"It's never straight up and down"     (DEVO)

Home | Main Index | Thread Index | Old Index