tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: self-conflicts and new pkg_install?

On Fri, 13 Feb 2009 22:19:44 +0900, Joerg Sonnenberger 
<> wrote:

> On Fri, Feb 13, 2009 at 01:03:22PM +0900, OBATA Akio wrote:
>> % sudo /usr/pkg/sbin/pkg_add -u 
>> /usr/pkgsrc/packages/4.0/i386/All/mysql-client-5.0.67nb2.tgz
>> pkg_add: Package `mysql-client-5.0.67nb2' conflicts with 
>> `{mysql-client-[0-9]*,mysql3-client-[0-9]*}', and `mysql-client-5.0.67nb1' 
>> is installed.
>> pkg_add: 1 package addition failed
> Can you check that the latest version in pkgsrc fixes that?


cc -L/pkg_comp/obj/pkgsrc/pkgtools/pkg_install/default/libarchive/.libs 
-L/pkg_comp/obj/pkgsrc/pkgtools/pkg_install/default/libnbcompat -L/usr/lib 
-Wl,-R/usr/lib -Wl,-R/usr/pkg/lib -L../lib -o pkg_info main.o perform.o show.o 
-linstall -larchive -lfetch -lbz2 -lz -lnbcompat
../lib/libinstall.a(pkcs7.o): In function `file_to_certs':
pkcs7.c:(.text+0x7d): undefined reference to `sk_new_null'
pkcs7.c:(.text+0x8d): undefined reference to `sk_num'
(...and tons lines)

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index