tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems with old "p5" packages and new "perl5" package

> On Sun, 12 Oct 2008 20:33:42 +0900, Matthias Scheler 
> <> wrote:
> > Perl packages that were built with version 5.8.* of the "perl5" package
> > install files into "/usr/pkg/lib/perl5/vendor_perl/5.8.0". The new
> > 5.10.0 version of the "perl5" package will however not find the files
> > in that directory, it looks in "/usr/pkg/lib/perl5/vendor_perl/5.10.0".
> >
> > This introduces a binary package incompabitility. What is the best way
> > to deal with that?
> Bump PERL5_REQD in lang/perl5/ [...]

That has now been done, finally.

> [...] and bump all perl module packages,
> same as when perl5 updated to 5.8.7, changed from "site" to "vendor".

I have two questions about this:

1) Why, exactly, is this necessary?  If one follows the normal
   pkgsrc dependency rules, as is done by "make update" or the
   traditional or new pkgsrc bulk builds, when a package a given
   package depends on has been updated, you need to rebuild the
   package in question too.

2) What is the easiest way to compute the set of packages which
   should be bumped?  (Given that I can be convinced it's really
   required, ref. above.)  I've looked at the revbump package and
   its finddepends script, but as it stands, it won't be able to
   handle p5-* packages because for the typical p5-* packages,
   the dependency is via perl5's, not directly on
   perl5's make fragment file.

Best regards,

- Håvard

Home | Main Index | Thread Index | Old Index