tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/editors - deprecated platforms

Moving this to tech-pkg rather than pkgsrc-changes

On Monday 13 October 2008 13:43:40 Masao Uebayashi wrote:
> > *** Deprecated machine types
> > pmax, hp9000s300, ibm370aix, ncr386, ews4800, mips-siemens, powerpcle,
> > and tandem-s2
> >
> > *** Deprecated operating systems
> > bsd386, bsdos2-1, bsdos2, bsdos3, bsdos4, bsd4-1, bsd4-2, bsd4-3,
> > usg5-0, usg5-2-2, usg5-2, usg5-3, ultrix4-3, 386bsd, hpux, hpux8,
> > hpux9, hpux9shr, hpux10, hpux10-20, aix3-1, aix3-2-5, aix3-2, aix4-1,
> > nextstep, ux4800, uxpds, and uxpv
> What part prevented you from updating?

So this list includes several that we supposedly support:
        m68k-*-netbsd*) machine=hp9000s300 ;;
        mips-*-netbsd*) machine=pmax ;;
      mipsel-*-netbsd*) machine=pmax ;;
      mipseb-*-netbsd*) machine=pmax ;;

       hpux pre 11
       aix pre 4.2

but with the update they wont build unless you comment out the two lines in 
the configure script that stop them and if we do that in package patches 
then anyone building on one of the deprecated platforms never gets to see 
the message that they should contact and tell 
that the platform is in use making it more likely that the support really 
does dissapear in the next major release.

Whether anyone is likely to want to build it on any of these platforms, I 
can't say.



Home | Main Index | Thread Index | Old Index