tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Updating gstreamer and question about tools dependency


The new GStreamer (0.10.20) desires flex>=2.5.31 (and yes, I think
this is genuinely required, but I'm not
positive).  On NetBSD, flex is a built-in tool; furthermore, as of now
we don't have any BUILDLINK_*_DEPENDS
entries in devel/flex/

Is there a way (without resorting to writing my own rules to do this
within the package Makefile) to check the
version of flex provided by the base system before resorting to using
a pkgsrc-provided flex?  I thought
it would be nice to have pkgsrc do the "right thing" should NetBSD's
flex one day satisfy the dependency ...



Home | Main Index | Thread Index | Old Index