Subject: Problems with checkperms-1.10 on a new PC
To: None <>
From: Martti Kuparinen <>
List: tech-pkg
Date: 12/11/2007 12:20:57
I have a new NetBSD/amd64 4.99.x installation and I tried to install some 
packages. I have


in /etc/mk.conf and installation of checkperms-1.10  fails like this

# pkg_info
digest-20070803     Message digest wrapper utility

# make update
=> Bootstrap dependency digest>=20010302: found digest-20070803
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `download-vulnerability-list'.
=> Checksum SHA1 OK for checkperms-1.10.tar.gz
=> Checksum RMD160 OK for checkperms-1.10.tar.gz
===> Installing dependencies for checkperms-1.10
===> Overriding tools for checkperms-1.10
===> Extracting for checkperms-1.10
===> Patching for checkperms-1.10
===> Creating toolchain wrappers for checkperms-1.10
===> Configuring for checkperms-1.10
=> Checking for portability problems in extracted files
===> Building for checkperms-1.10
rm -f .gdbinit
touch .gdbinit
#   compile  checkperms-1.10/checkperms.o
cc -O2 -pipe  -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith 
-Wno-sign-compare -Wno-traditional -Wreturn-type -Wswitch -Wshadow -Wcast-qual 
-Wwrite-strings -Wextra -Wno-unused-parameter -std=gnu99  -Werror      -c 
#      link  checkperms-1.10/checkperms
cc -Wl,-R/usr/pkg/lib      -o checkperms  -Wl,-rpath-link,/lib:/usr/lib  -L/lib 
#    format  checkperms-1.10/checkperms.cat1
nroff -mandoc checkperms.1   > checkperms.cat1.tmp && mv checkperms.cat1.tmp 
=> Unwrapping files-to-be-installed.
===> Installing for checkperms-1.10
=> Generating pre-install file lists
#   install  /usr/pkg/bin/checkperms
install  -c  -r -o root -g wheel -m 555   checkperms /usr/pkg/bin/checkperms
#   install  /usr/pkg/man/cat1/checkperms.0
install  -c  -r -o root -g wheel -m 444  checkperms.cat1 
install: /usr/pkg/man/cat1: mkstemp: No such file or directory
*** Error code 1

Anyone else having this kind of problem?