Subject: Re: lang/ruby18-base fails to build on netbsd-3 i386
To: None <>
From: Takahiro Kambe <>
List: tech-pkg
Date: 11/20/2007 00:55:10

In message <>
	on Mon, 19 Nov 2007 01:24:16 -0500,
	Louis Guillaume <> wrote:
> > BTW, what is your hardware environment?
> > 
> Actually I was removing the PKG_OPTION with the `-' to get it to work.
> My hardware is i386. Very plain.
It dosen't have useful information that "Very plain."  What is your
machine's CPU and how many memory dose it have?

> My suspicion at this point is that I'm running out of disk. I have some 
> reports of this in dmesg. And /home is 94% before running the build. 
> Does ruby-build-ri-db require ~512M ?? That's about what I have left. 
> Subtract of course the extract of the source packages for ruby.

% du -sk /work/NetBSD-3/i386.pkg_comp/pkg_comp/obj/pkgsrc/lang/ruby18-base/default 
62606 /work/NetBSD-3/i386.pkg_comp/pkg_comp/obj/pkgsrc/lang/ruby18-base/default

Bulding ri's db dosen't consume working area, but installing file
system and runtime memory.

Takahiro Kambe <>