Subject: Re: Webalizer vs. libdb*
To: Martin Husemann <>
From: Greg Troxel <>
List: tech-pkg
Date: 11/14/2007 11:48:18
Martin Husemann <> writes:

> On Tue, Nov 13, 2007 at 09:35:15AM -0500, Johnny C. Lam wrote:
>> I think BDB_DEFAULT is a user-settable, not a package-settable value, 
>> and so it shouldn't be set here in the package Makefile.
> Well, it does not work for me if I don't set it: it picks db4 as
> default then (maybe since I have that installed already), and then fails
> because it is not in BDB_ACCEPTED.

In general these mechanisms need to express what flavors work with the
package (_ACCEPTED?), what versions are allowable by the user, and what
version is preferred, and find the most preferred version out of the
accepted set.  It sounds like something needs spiffing up here.