Subject: Re: ABI for glib2 changed
To: Tobias Nygren <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/30/2007 15:15:18
> Anyway, please bump the ABI dependency if it's needed. Btw, I don't
> understand how a gnome-vfs2 built against glib 2.12 can have a PLT
> reference to something that was introduced in glib-2.13?

The gnome-vfs package came from NetBSD's FTP download (provided by bouyer 
I think) and built with @blddep glib2-2.14.1

But pkg_add uses @pkgdep (glib2>=2.9.3) so my already installed 
glib2-2.12.4 was good enough.

I do not want to periodically reinstall every package on my system. My use 
of a package system is to install what I use and upgrade for what I need 
and allow the package tools (or pkgsrc build infrastructure) handle 
upgrading requirements for me. For critical systems I also attempt to 
upgrade based on pkg-vulnerability reports.

One of my systems has many old packages including 34 packages installed in 
2005 and 328 packages installed in 2006.

  Jeremy C. Reed