Subject: Re: amd64 cvsup Re: rsync-2.6.9 has a remote-user-shell
To: None <>
From: George Georgalis <>
List: tech-pkg
Date: 10/08/2007 13:12:08
On Mon, Oct 08, 2007 at 05:25:58PM +0100, Adrian Portelli wrote:
>George Georgalis wrote:
>> Since amd64 cvsup is broken, there is not a good way (which I know
>> about) to get netbsd rcs files. I need a local mirror due to the
>> number of hosts on my nat. So I've been maintaining a checkout of
>> each of the various tags I need and propagating them to hosts on
>> my local nat. -- that process was broken.
>Have you tried net/csup instead ?

it only supports "checkout" mode so I can't use it to populate a
mirror with rcs files, only clients from an already existing rcs

>Also, I thought I remember reading a few threads a while ago about cvsup
>on amd64 and I thought it got resolved.  I think the ppl came
>across the issue.  Try looking through some old mail archives on
> and see how you get on.

That's better than any info I came up with,
ezm3 / Easier, more portable Modula-3 distribution for building CVSup

My understanding is lang/ezm3 doesn't build on netbsd amd64, but
it was worked out on freebsd ports. Per above posts (especially
the 08/22/2007 followup) it seems like amd64 might be fixed in
head, not sure if that means it is slated for Q3, even if it
does work now.

Has anyone confirmed it works? If so, is it going in Q3 or what's
needed to pull up to stable? I cannot use head, but I'll find time
to try it if that's necessary for a pull up.

// George

George Georgalis, information system scientist <IXOYE><