Subject: buildlinking problem with gtkmm
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/03/2007 11:25:42
I don't know if this is a problem with the buildlinking infrastructure or 
if just a package should have its BUILDLINK_API_DEPENDS increased.

Trying to build something that includes gtkmm buildlink fails with:

===> Creating toolchain wrappers for passepartout-0.7.0
ERROR: cairomm is not installed; can't buildlink files.
*** Error code 1

I have gtkmm-2.8.8 installed in August 2006.

Recent gtkmm buildlink has:

BUILDLINK_API_DEPENDS.gtkmm+=   gtkmm>=2.6.3
BUILDLINK_ABI_DEPENDS.gtkmm+=   gtkmm>=2.10.1


.include "../../graphics/cairomm/"

This cairomm include addition happened in revision 1.13 back in September 
of 2006 when it went from 2.8.8 to 2.10.2.

I don't have cairomm installed but according to buildlink, my gtkmm is 
good enough.

Okay, if we change the BUILDLINK_API_DEPENDS.gtkmm to gtkmm>=2.10.1 (or 

Or is something else wrong?

  Jeremy C. Reed